A passionate openSUSE user
RSS icon Home icon
  • Compiz 0.9.0 released

    Posted on July 4th, 2010 Dominique Leuenberger 8 comments

    Compiz has been in the works for a long time, but just now 0.9.0 has been released.

    Packages for openSUSE are on their way and will arrive in OBS://X11:Compiz:Next in a few minutes.
    THEY ARE COMPLETELY UNTESTED BY ME YET

    Read the rest of this entry »

  • Compiz 0.8.6 for openSUSE 11.0 and 11.1

    Posted on May 11th, 2010 Dominique Leuenberger 6 comments

    A fellow openSUSE user (David) kindly asked me if it would be possible to provide newer compiz also for the somewhat ‘older’ openSUSE distributions (he is currently running 11.0 as I understood).

    Not knowing what I will run into I took the challenge and tried to fix the build failures of compiz 0.8.6 (I hope this is not to new for you now David! you asked for 0.8.4 :) ) and went ahead. All it needed was one single patch reverting some of the GTK fixes back to the old, deprecated GTK calls and it all seemed to build fine.

    The updated packages are being built in the openSUSE Build Service Project X11:Compiz (the development project of compiz, same source as is being used in openSUSE Factory).

    A warning though: I do not have any openSUSE installation < 11.2 available and could thus not test if the packages do work at all (but considering that they do work on Factory, there are some chances).

    A side note though: do not start it by simply invoking compiz –replace if your user does not have a compiz configuration, as compiz on it’s own no longer loads any standard plug-ins (as it did in older releases). This was all outsources to compiz-manager, that takes care of loading a minimal set of plug-ins for you (so invoke compiz-manager –replace).